Back in Time (root) startet nicht Automatisch

Hilfe bei der Installation von Manjaro Linux!

Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#16

#16 Beitrag von Daemon » Freitag 8. November 2019, 17:11

Lucius hat geschrieben:
Freitag 8. November 2019, 17:00
Ich kann dich schon verstehen, nur bevor ich hier ein Thema aufmache, suche ich erstmal selbst.
Warum ein neues Thema? Gehört doch zu deinem Problem.
Und selbst gesucht hast du ja nicht, sonst hättest du die Befehle gefunden. ;)

Wie auch immer, hier die Lösung:

Code: Alles auswählen

sudo systemctl start cronie
sudo systemctl enable cronie
Neustart, und dann nochmal mit

Code: Alles auswählen

journalctl -b -u cron*

kontrollieren.

Das war, wie ich bereits vor einigen Beiträgen schon vermutet habe, das Problem. Der cron Service läuft nicht.

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#17

#17 Beitrag von Lucius » Freitag 8. November 2019, 17:21

Du hast mich missverstanden :) Ich meinte eher damit das ich nicht direkt hier ein Thema eröffne,
sondern erst selber schaue ob ich das Problem lösen kann.

Nach den Neustart:

Code: Alles auswählen

-- Logs begin at Mon 2019-10-28 21:48:29 CET, end at Fri 2019-11-08 17:19:51 CET. --
-- No entries --
Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#18

#18 Beitrag von Daemon » Freitag 8. November 2019, 17:26

Das habe ich dann tatsächlich missverstanden.

Mach mal folgende Befehle nacheinander und zeige die Ausgabe:

Code: Alles auswählen

sudo systemctl start unit
systemctl is-enabled unit
sudo systemctl enable --now unit

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#19

#19 Beitrag von Lucius » Freitag 8. November 2019, 17:39

Hmm sieht nicht gut aus :(

Code: Alles auswählen

Failed to start unit.service: Unit unit.service not found.

Failed to get unit file state for unit.service: No such file or directory

Failed to enable unit: Unit file unit.service does not exist.


Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#20

#20 Beitrag von Daemon » Freitag 8. November 2019, 18:07

Öhm, jo, anstatt unit halt cronie einsetzen.

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#21

#21 Beitrag von Lucius » Freitag 8. November 2019, 18:42

Code: Alles auswählen

sudo systemctl start cronie
Keine Meldung

systemctl is-enabled cronie
enabled

sudo systemctl enable --now cronie
keine meldung
Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#22

#22 Beitrag von Daemon » Freitag 8. November 2019, 18:50

Dann müsste es nach einem Neustart eigentlich laufen.

Und dann nochmal die Ausgabe von

Code: Alles auswählen

systemctl status cronie

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#23

#23 Beitrag von Lucius » Freitag 8. November 2019, 19:10

Code: Alles auswählen

systemctl status cronie
● cronie.service - Periodic Command Scheduler
   Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2019-11-08 17:16:05 CET; 1h 53min ago
 Main PID: 812 (crond)
    Tasks: 3 (limit: 4915)
   Memory: 20.2M
   CGroup: /system.slice/cronie.service
           ├─  812 /usr/bin/crond -n
           ├─18555 python -Es /usr/share/backintime/common/backintime.py pw-cache start
           └─18685 /usr/sbin/anacron -s

Nov 08 19:00:01 LUX CROND[2884]: (lucius) CMD (/usr/bin/nice -n19 /usr/bin/ionice -c2 -n7 /usr/bin/backintime backup-job >/dev/null)
Nov 08 19:00:01 LUX python[2898]: backintime (root/1): INFO: Lock
Nov 08 19:00:01 LUX CROND[2882]: pam_unix(crond:session): session closed for user root
Nov 08 19:00:01 LUX python[2907]: backintime (lucius/1): INFO: Lock
Nov 08 19:00:01 LUX CROND[2881]: pam_unix(crond:session): session closed for user lucius
Nov 08 19:00:01 LUX python[2898]: backintime (root/1): ERROR: Passwortlose Anmeldung von root@192.168.1.10 fehlgeschlagen. Weitere Informationen unter »man backintime«.
                                  
                                  root@192.168.1.10: Permission denied (publickey,password,keyboard-interactive).
Nov 08 19:00:01 LUX python[2898]: backintime (root/1): INFO: Unlock
Nov 08 19:00:01 LUX python[2907]: backintime (lucius/1): ERROR: Passwortlose Anmeldung von root@192.168.1.10 fehlgeschlagen. Weitere Informationen unter »man backintime«.
                                  
                                  root@192.168.1.10: Permission denied (publickey,password,keyboard-interactive).
Nov 08 19:00:01 LUX python[2907]: backintime (lucius/1): INFO: Unlock
Nov 08 19:01:01 LUX CROND[3047]: (root) CMD (run-parts /etc/cron.hourly)


Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#24

#24 Beitrag von Daemon » Freitag 8. November 2019, 19:14

Ok, also cron läuft ja jetzt mal.

Nun noch das Problem mit BackInTime erledigen.

Kann sich nicht Passwortlos anmelden.

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#25

#25 Beitrag von Lucius » Freitag 8. November 2019, 19:29

Woran liegt das? bzw. woran kann das überhaupt liegen?
Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#26

#26 Beitrag von Daemon » Freitag 8. November 2019, 20:32

gosia hat geschrieben:
Montag 4. November 2019, 11:46
Ich habe das mal in einer VM nachgespielt und hatte keine Probleme, da startet Backintime brav aller 10 Minuten, ohne daß ich extra was machen musste. Backintime (root) aufgerufen, Quelle, Ziel und Zeitraum eingestellt, das war alles.
Mehr musst du eigentlich nicht machen. Cron läuft ja jetzt, also scheint dann nur noch die Config von BiT nicht zu stimmen.

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#27

#27 Beitrag von Lucius » Samstag 9. November 2019, 10:16

Oh man sorry, ich habe als ich diesen Beitrag erstellt hatte, bereits eine Verbindung über BackInTime über rsa hergestellt,
allerdings hab ich in der Zeit als ich versucht habe sshfs über fstab die rsa für diesen Zweck überschrieben.

Er konnte sich deshalb nicht mit dem Server verbinden :) (Peinlich)
Soeben bemerkte ich beim Musik hören, das ich kein neues Lied per plex auswählen konnte und das der Server arbeitet,
da machte ich doch glatt:

systemctl status cronie

Code: Alles auswählen


● cronie.service - Periodic Command Scheduler
   Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2019-11-09 09:24:23 CET; 50min ago
 Main PID: 838 (crond)
    Tasks: 16 (limit: 4915)
   Memory: 10.6G
   CGroup: /system.slice/cronie.service
           ├─  838 /usr/bin/crond -n
           ├─19323 python -Es /usr/share/backintime/common/backintime.py backup-job
           ├─19332 /usr/bin/ssh-agent
           ├─19349 python -Es /usr/share/backintime/common/backintime.py pw-cache start
           ├─19353 ssh -x -a -oClearAllForwardings=yes -oServerAliveInterval=240 -oLogLevel=Error -oIdentityFile=/root/.ssh/id_rsa -oPort=40591 -2 root@192.168.1.10 -s sftp
           ├─19355 sshfs -o ServerAliveInterval=240 -o LogLevel=Error -o IdentityFile=/root/.ssh/id_rsa -p 40591 -o idmap=user -o cache_dir_timeout=2 -o cache_stat_timeout=2 root@192.168.1.10:/mnt/di>
           ├─19359 /usr/bin/python /usr/share/backintime/qt/qtsystrayicon.py 1
           ├─19363 rsync --recursive --times --devices --specials --hard-links --human-readable --links --perms --executability --group --owner --info=progress2 --no-inc-recursive --rsh=ssh -o Server>
           ├─19364 ssh -o ServerAliveInterval=240 -o LogLevel=Error -o IdentityFile=/root/.ssh/id_rsa -p 40591 -l root 192.168.1.10 rsync --server -vlHogDtpre.LsfxC --log-format=%i --delete-excluded >
           └─19515 /usr/sbin/anacron -s

Nov 09 10:00:01 LUX python[19359]: QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Nov 09 10:00:01 LUX python[19359]: qt5ct: using qt5ct plugin
Nov 09 10:00:01 LUX python[19323]: backintime (root/1): INFO: Take a new snapshot. Profile: 1 Hauptprofil
Nov 09 10:00:02 LUX python[19323]: backintime (root/1): INFO: Found leftover 'new_snapshot' which can be continued.
Nov 09 10:00:02 LUX python[19359]: qt5ct: D-Bus system tray: no
Nov 09 10:00:02 LUX python[19323]: backintime (root/1): INFO: Call rsync to take the snapshot
Nov 09 10:01:01 LUX CROND[19510]: (root) CMD (run-parts /etc/cron.hourly)
Nov 09 10:01:01 LUX anacron[19515]: Anacron started on 2019-11-09
Nov 09 10:01:01 LUX anacron[19515]: Will run job `cron.daily' in 45 min.
Nov 09 10:01:01 LUX anacron[19515]: Jobs will be executed sequentially
lines 1-28/28 (END)

Siehe an, er macht über root ein automatisches Backup :) Danke für die Hilfe :D
Liebe Grüße
Lucius

Antworten