Back in Time (root) startet nicht Automatisch

Hilfe bei der Installation von Manjaro Linux!
Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Back in Time (root) startet nicht Automatisch

#1

#1 Beitrag von Lucius » Sonntag 27. Oktober 2019, 17:23

Guten Abend liebe Community,

ich mal wieder mit meinen Problemen^^
Kurz und schmerzlos, ich habe Backintime Konfiguriert und so angepasst wie ich so denke,
gestartet habe ich BackinTime als root, damit er alle Daten ohne Einschränkung Lesen und backupen kann.

Als Normaler User kommen mir zu viele Fehlermeldungen die bei einen Backup/Snapshot nicht kommen sollte.
Ein Snapshot soll stündlich auf meinen NAS Server erstellt werden, das auch bei Manueller Ausführung klappt, aber wenn ich den Rechner neustarte,
legt er keine weiteren Snapshots mehr an.

Bild Bild Bild Bild
Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#2

#2 Beitrag von Daemon » Sonntag 27. Oktober 2019, 17:40

Dann wurde der cronjob nicht angelegt. Schau mal nach mit crontab -e
Oder das tolle systemd hat cron gar nicht gestartet.

Hiermit kannst du dir alle cron jobs von jedem User anzeigen lassen:

Code: Alles auswählen

for user in $(cut -f1 -d: /etc/passwd); do crontab -u $user -l; done

EDIT:
Und bitte Bilder zukünftig hier hochladen. Danke.

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#3

#3 Beitrag von Lucius » Sonntag 27. Oktober 2019, 18:23

Hi Daemon :)

Dann spuckt er diese Meldung aus:

Code: Alles auswählen

must be privileged to use -u
Mach ich irgendwas falsch?
Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#4

#4 Beitrag von Daemon » Sonntag 27. Oktober 2019, 18:30

Mit sudo ausführen.


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#5

#5 Beitrag von Daemon » Sonntag 27. Oktober 2019, 18:30

Mit sudo ausführen.

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#6

#6 Beitrag von Lucius » Sonntag 27. Oktober 2019, 21:40

Geht leider nicht, bekomme dann diesen Fehler:

Code: Alles auswählen

sudo for user in $(cut -f1 -d: /etc/passwd); do crontab -u $user -l; done
bash: Syntaxfehler beim unerwarteten Wort `do'

Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#7

#7 Beitrag von Daemon » Montag 28. Oktober 2019, 17:14

Ja stimmt, gerade nochmal überprüft.
Dann machen wir es anders. Lege dir eine Datei an, z.B. mit dem Namen croncheck.sh in deinem home Verzeichnis, mit diesem Inhalt.

Code: Alles auswählen

for user in $(cut -f1 -d: /etc/passwd)
    do crontab -u $user -l
done
Dann im Terminal (musst aber in deinem home Verzeichnis sein, was eigentlich so ist wenn man das Terminal frisch öffnet):

Code: Alles auswählen

chmod +x croncheck.sh
Und dann immer noch im Terminal dies machen

Code: Alles auswählen

sudo ./croncheck.sh
(da sollte dann die PW Abfrage von sudo kommen)

Bei mir kommt dann z.B. das hier:

Code: Alles auswählen

no crontab for root
no crontab for bin
no crontab for daemon
no crontab for mail
no crontab for ftp
no crontab for http
no crontab for nobody
no crontab for dbus
no crontab for dnsmasq
no crontab for rpc
no crontab for uuidd
no crontab for avahi
no crontab for colord
no crontab for ntp
no crontab for polkitd
no crontab for sddm
no crontab for usbmux
no crontab for rtkit
no crontab for mysql
no crontab for git
no crontab for cups

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#8

#8 Beitrag von Lucius » Montag 28. Oktober 2019, 20:40

Nabend :) Jetzt hat es geklappt:

Code: Alles auswählen

#Back In Time system entry, this will be edited by the gui:
0 * * * * /usr/sbin/nice -n19 /usr/sbin/ionice -c2 -n7 /usr/sbin/backintime backup-job >/dev/null

no crontab for nobody
no crontab for dbus
no crontab for bin
no crontab for daemon
no crontab for mail
no crontab for ftp
no crontab for http
no crontab for systemd-journal-remote
no crontab for systemd-network
no crontab for systemd-resolve
no crontab for systemd-timesync
no crontab for systemd-coredump
no crontab for uuidd
no crontab for dnsmasq
no crontab for rpc
no crontab for gdm
no crontab for avahi
no crontab for colord
no crontab for cups
no crontab for flatpak
no crontab for geoclue
no crontab for git
no crontab for nm-openconnect
no crontab for nm-openvpn
no crontab for ntp
no crontab for polkitd
no crontab for rtkit
no crontab for usbmux
#Back In Time system entry, this will be edited by the gui:
0 * * * * /usr/bin/nice -n19 /usr/bin/ionice -c2 -n7 /usr/bin/backintime backup-job >/dev/null

no crontab for nvidia-persistenced
no crontab for mysql
no crontab for plex
no crontab for brscan-skey
no crontab for gluster

Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#9

#9 Beitrag von Daemon » Montag 28. Oktober 2019, 20:52

Und jetzt noch nachschauen ob der cron überhaupt läuft.

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#10

#10 Beitrag von Lucius » Montag 28. Oktober 2019, 22:52

WIe mach ich das? denn Snapshots erstellt er nicht automatisch.
Liebe Grüße
Lucius


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#11

#11 Beitrag von Daemon » Montag 28. Oktober 2019, 23:11

Wie wäre es mal mit Eigeninitiative, anstatt dass dir hier alles vorgekaut wird?

Du willst den Status von cron wissen, und dein Init system ist systemd. Dann gibt es noch die Befehle für "starten" und "aktivieren beim starten (vom OS)". Somit hast du alle Suchbegriffe die du brauchst. :)

Die Befehle kannst du dann auch bei anderen systemd relevanten Sachen gebrauchen (gibt natürlich noch mehr).

Hilfe zur Selbsthilfe ist besser als alles vorgesetzt zu bekommen. ;) Ansonsten könnte ich auch zur dir gefahren kommen und es gleich selbst machen. :)

EDIT:
https://wiki.archlinux.org/index.php/Systemd

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#12

#12 Beitrag von Lucius » Sonntag 3. November 2019, 23:05

Ne du sollst mir nichts vorzukauen, allerdings ist es immer schwer aus nichts mehr zu machen :)

Das Problem mit dem BackInTime besteht schon länger,
allerdings gibt es unzählige Lösungsmöglichkeiten die mir bei nicht klappen :)
Liebe Grüße
Lucius

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 970
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 121 Mal

Re: Back in Time (root) startet nicht Automatisch

#13

#13 Beitrag von gosia » Montag 4. November 2019, 11:46

Hallo Lucius,
Lucius hat geschrieben:
Sonntag 3. November 2019, 23:05
allerdings ist es immer schwer aus nichts mehr zu machen
Naja, das gilt für Lösungsversuche aber auch und außer "es funktioniert nicht" haben wir nicht gerade viel.
Ich habe das mal in einer VM nachgespielt und hatte keine Probleme, da startet Backintime brav aller 10 Minuten, ohne daß ich extra was machen musste. Backintime (root) aufgerufen, Quelle, Ziel und Zeitraum eingestellt, das war alles.
Aber da das niemanden weiterhilft, liefere uns doch mal paar Fakten:
Was sagt

Code: Alles auswählen

systemctl status cronie
journalctl -b -u cron*
bei letzterem Befehl mindestens die 10 Minuten nach dem Booten abwarten, aber so max. 15 Minuten Wartezeit sollten reichen (es sei denn, Du hast den Zeitraum von Backintime inzwischen vergrössert, dann eben entsprechend länger warten)

viele Grüße gosia


Daemon
Forum Kenner
Forum Kenner
Beiträge: 242
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Back in Time (root) startet nicht Automatisch

#14

#14 Beitrag von Daemon » Montag 4. November 2019, 16:03

Lucius hat geschrieben:
Sonntag 3. November 2019, 23:05
Ne du sollst mir nichts vorzukauen, allerdings ist es immer schwer aus nichts mehr zu machen :)
Mit den Suchbegriffen, die ich dir schon gegeben habe (systemd status Programm/Dienst), hättest du aber selbst mal suchen können wie man sich den Status eines Programmes/Dienstes anzeigen lassen kann.
Rausgekommen wäre dann das, was gosia dir geschrieben hat.

Hört sich wieder aggressiv/asozial an, aber ich bin es ja gewohnt das mir das angekreidet wird. ;)

Benutzeravatar

Themen Author
Lucius
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 73
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: x86_64 Linux 5.3.6-1-MANJARO
DE: GNOME 3.34.1 (X11)
GPU Treiber: Nvidia Driver 435.21
Hat sich bedankt: 6 Mal
Danksagung erhalten: 2 Mal

Re: Back in Time (root) startet nicht Automatisch

#15

#15 Beitrag von Lucius » Freitag 8. November 2019, 17:00

Ich kann dich schon verstehen, nur bevor ich hier ein Thema aufmache, suche ich erstmal selbst.

systemctl status cronie:

Code: Alles auswählen

● cronie.service - Periodic Command Scheduler
   Loaded: loaded (/usr/lib/systemd/system/cronie.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
journalctl -b -u cron*:

Code: Alles auswählen

-- Logs begin at Mon 2019-10-28 21:48:29 CET, end at Fri 2019-11-08 16:55:43 CET. --
-- No entries --
Man darf auch nicht vergessen, das ich erst vor kurzen vollständig umgestiegen bin,
ich bin immernoch Windows Geschädigt^^ Linux hab ich nur auf Servern oder als Zweites Betriebssystem genutzt.
Liebe Grüße
Lucius

Antworten