Packet hplip Konflikt bei Update

Frische News und Updates zu Manjaro Linux finden sich zeitnah hier ein!
Antworten

Themen Author
sdoubleu
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 21
Registriert: Mittwoch 20. März 2019, 08:01
CPU: Intel I5-2500
GPU: Zotac Nvidia GT610
Kernel: 5.4.18 LTS
DE: XFCE
GPU Treiber: proprietär

Packet hplip Konflikt bei Update

#1

#1 Beitrag von sdoubleu »

Hallo,
bei meinem heutigen Update ist der folgende Fehler mit dem Paket hplip aufgetreten.

Code: Alles auswählen

Pakete (1) hplip-1:3.20.3-2
Gesamtgröße der installierten Pakete:  30,58 MiB
Größendifferenz der Aktualisierung:   3,41 MiB

Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
hplip: /usr/share/hplip/base/__pycache__/__init__.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/avahi.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/codes.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/device.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/g.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/logger.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/mdns.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/models.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/os_utils.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/pml.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/services.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/six.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/sixext.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/slp.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/status.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/strings.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/tui.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/__pycache__/utils.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/base/pexpect/__pycache__/__init__.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/__pycache__/__init__.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/__pycache__/cups.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/__pycache__/ldl.cpython-38.pyc existiert im Dateisystem
hplip: /usr/share/hplip/prnt/__pycache__/pcl.cpython-38.pyc existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
Wie kann ich das Problem lösen? Kann ich aktiv eingreifen oder soll ich warten, bis es eine Nachbesserung gibt und dann später updaten?
Danke.

Benutzeravatar

manjarofan
Administrator
Administrator
Beiträge: 1172
Registriert: Dienstag 24. November 2015, 08:43
Wohnort: Sachsen
CPU: Intel® Core™ i7-2630QM
GPU: Nvidia Geforce GT 650M
Kernel: 5.3
DE: Manjaro MATE 18.1
GPU Treiber: Free
Hat sich bedankt: 113 Mal
Danksagung erhalten: 74 Mal
Kontaktdaten:

Re: Packet hplip Konflikt bei Update

#2

#2 Beitrag von manjarofan »

Selbiges Problem habe Ich auch. Habe den HP Device Manager deinstalliert erstmal. System läuft deshalb trotzdem rund.....

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 216
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: AMD Phenom II P920
GPU: AMD RS880M
Kernel: 5.5
DE: XFCE
GPU Treiber: free
Danksagung erhalten: 15 Mal

Re: Packet hplip Konflikt bei Update

#3

#3 Beitrag von Josef_K »

Hallo sdoubleu,

wenn du keinen HP-Drucker hast, kannst du hplip einfach entfernen, wird nur von HP-Geräten benötigt. Hab ich auch schon vor langer Zeit gemacht.

Grüsse
Josef


MichaelP
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 46
Registriert: Samstag 26. Januar 2019, 13:25
CPU: AMD Ryzen 7 1800
GPU: NVIDIA GT1080
Kernel: 5.5.2
DE: keine Ahnung
GPU Treiber: video-nvidia-440xx
Hat sich bedankt: 1 Mal
Danksagung erhalten: 2 Mal

Re: Packet hplip Konflikt bei Update

#4

#4 Beitrag von MichaelP »

Hallo Sdoublue,

PAMAC hat bei mir bei der SW-Intitialisierung gestoppt und ein Fehlerfenster zu hplip angezeigt.
Hab ich geschlossen, PAMAC geschlossen und Manjaro neu gebootet.
Beim zweiten PAMAC-Aufruf ist das Update problemfrei durchgelaufen.
Verstehen tue ich es nicht.

Wenn es bei Dir sooo nicht klappt, vielleicht hplip temporär deinstallieren und nach Update
reinstallieren.

Ist ja nicht "existenziell" für den Start & Flug von Pinguinen ;-)

Gruß Michael


Themen Author
sdoubleu
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 21
Registriert: Mittwoch 20. März 2019, 08:01
CPU: Intel I5-2500
GPU: Zotac Nvidia GT610
Kernel: 5.4.18 LTS
DE: XFCE
GPU Treiber: proprietär

Re: Packet hplip Konflikt bei Update

#5

#5 Beitrag von sdoubleu »

Danke für die schnellen Antworten.
Ich dachte, dass es vielleicht auch für andere Drucker außer HP notwendig ist.
Scheinbar nicht. Ich habe es jetzt einfach deinstalliert.


TimTiger
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 7
Registriert: Dienstag 25. Februar 2020, 19:32
CPU: i9 9900k
GPU: nvidia 2080
Kernel: 5.5.5.
DE: KDE-Plasma
GPU Treiber: nvidia-dkms
Danksagung erhalten: 1 Mal

Re: Packet hplip Konflikt bei Update

#6

#6 Beitrag von TimTiger »

Ein Bug.
Ich habe die angemaulten Dateien gelöscht, danach lief das Update durch, allerdings mit einer Fehlermeldung.
"Verzeichnis-Berechtigungen unterscheiden sich für /usr/share/hplip/base/pexpect/__pycache__/"
Alle Drucker arbeiten normal.


TimTiger
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 7
Registriert: Dienstag 25. Februar 2020, 19:32
CPU: i9 9900k
GPU: nvidia 2080
Kernel: 5.5.5.
DE: KDE-Plasma
GPU Treiber: nvidia-dkms
Danksagung erhalten: 1 Mal

Re: Packet hplip Konflikt bei Update

#7

#7 Beitrag von TimTiger »


Antworten