HDD idle

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Antworten

Themen Author
Sedi
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 7
Registriert: Sonntag 9. Juni 2019, 14:46
CPU: i5-4200u
GPU: Intel Integrated HD-4400
Kernel: 4.19.45-1
DE: KDE
GPU Treiber: Mesa DRI Intel Haswell Mobile

HDD idle

#1

#1 Beitrag von Sedi » Sonntag 9. Juni 2019, 16:10

Hallo Manjaro fans.
Bin ganz neu in der Linux Welt und benötige eure Unterstützung.
Hab das Manjaro LTS KDE erfolgreich in Betrieb genommen und bin davon begeistert.
Bis auf ein paar Probleme wo ich noch kein Lösungsweg, mangels Linux terminal Kenntnisse, möchte ich auf einen dieser Propleme eingehen.

Für ein Backup habe ich timeshift installiert und auf die externe hdd per usb3.0 Eingestellt. Das manuelle Backup funktioniert ohne Probleme.
Das automatische Backup, eingestellt Stunde, Tag, Woche, Monat (probieren) funktioniert jedoch nicht automatisch.

Es liegt wohl daran das die externe hdd auf standby geht und timeshift diese wohl nicht aufweckt.

Was wäre also die beste Vorgehensweise?
Die externe hdd ist permanent angeschlossen und nur für das Manjaro genutzt. Keinerlei Daten bis auf die Backups.
Hab etwas gelesen mit hdparm / hdidle... Aber so richtig nicht verstanden.

Grüße
Sedi

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 787
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 5 Mal
Danksagung erhalten: 85 Mal

Re: HDD idle

#2

#2 Beitrag von gosia » Sonntag 9. Juni 2019, 17:06

Hallo Sedi,
erstmal herzlich willkommen hier im Forum :-*
Kontrolliere mal, ob der Dienst cronie überhaupt läuft

Code: Alles auswählen

systemctl status cronie.service
Wenn nicht, einschalten und starten

Code: Alles auswählen

sudo systemctl enable -now cronie.service
wenn das nicht hilft, mal den Eintrag in der crontab zeigen.

viele Grüße gosia


Themen Author
Sedi
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 7
Registriert: Sonntag 9. Juni 2019, 14:46
CPU: i5-4200u
GPU: Intel Integrated HD-4400
Kernel: 4.19.45-1
DE: KDE
GPU Treiber: Mesa DRI Intel Haswell Mobile

Re: HDD idle

#3

#3 Beitrag von Sedi » Sonntag 9. Juni 2019, 19:34

Gi Gosia,

Vielen Dank für deine Antwort.
Sobald ich daheim bin prüfe ich das.

Sorry aber da ich ganz neu in der Linux Welt bin, sagen mir die Begrifflichkeiten nichts.
Ich kenne auch nicht die terminal commands hierzu.
Crontab?

Sorry, kenne mich da nicht aus :)

hier nochmal die Ausgabe aus dem Terminal:
cronie.service - Periodic Command Scheduler
Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2019-06-09 20:32:11 CEST; 3min 1s ago

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 787
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 5 Mal
Danksagung erhalten: 85 Mal

Re: HDD idle

#4

#4 Beitrag von gosia » Sonntag 9. Juni 2019, 21:00

Hallo Sedi,
Sedi hat geschrieben:
Sonntag 9. Juni 2019, 19:34
Crontab?
Sorry, kenne mich da nicht aus
Ok, vergiss es. Das war meine Schuld. Bei timeshift trägst Du selbst nichts in die Crontab ein. Crontab ist so ein Mechanismus, bei dem man eintragen kann, daß zu bestimmten Zeiten irgendwelche Aufgaben ausgeführt werden sollen. Also z.B. jeden Montag um 13.00 Uhr soll ein Update gemacht werden. Sowas in der Art gibt es ja in Windows auch. Aber, wie gesagt, bei timeshift kann in dieser Richtung nichts schief gehen.
Also reicht es, wenn Du die angegebenen Befehle in ein Terminal eintippst und die Ausgabe hier postest.
Um es verständlicher zu machen, ein Beispiel:
Du stellst den Wecker auf 7.00 Uhr, damit er dich mit lautem Geratter um diese Zeit weckt (es handelt sich um so einen ganz altmodischen, mechanischen Wecker). Wenn der Wecker aber nicht aufgezogen wurde, hilft dir das gar nichts, weil er dann ewig auf 18.34 Uhr steht.
Tja, und in in deinem PC ist cronie sozusagen der Wecker und wir müssen nachsehen, ob er "aufgezogen" wurde und auch "läuft". Und genau das machen die beiden Befehle:

Code: Alles auswählen

systemctl status cronie.service
sieht nach, ob der Wecker aufgezogen ist ;)
Ist das nicht der Fall, zieht der nächste Befehl den Wecker auf

Code: Alles auswählen

sudo systemctl enable -now cronie.service
Etwas verständlicher jetzt?
Kann natürlich beides in Ordnung sein, aber irgendwo müssen wir ja anfangen.

viele Grüße gosia


Themen Author
Sedi
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 7
Registriert: Sonntag 9. Juni 2019, 14:46
CPU: i5-4200u
GPU: Intel Integrated HD-4400
Kernel: 4.19.45-1
DE: KDE
GPU Treiber: Mesa DRI Intel Haswell Mobile

Re: HDD idle

#5

#5 Beitrag von Sedi » Montag 10. Juni 2019, 01:36

Hi Gosia,

kein Problem :-)
vielen Dank, ich verstehe den Zusammenhang ;-)
Der Service selbst läuft wohl:

ERGEBNIS:

● cronie.service - Periodic Command Scheduler
Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2019-06-10 01:24:46 CEST; 1min 34s ago
Main PID: 554 (crond)
Tasks: 4 (limit: 4915)
Memory: 2.0M
CGroup: /system.slice/cronie.service
├─554 /usr/bin/crond -n
├─556 /usr/bin/CROND -n
├─568 /bin/bash -c sleep 10m && timeshift --create --scripted --tags B
└─651 sleep 10m

Jun 10 01:24:46 t440-linux systemd[1]: Started Periodic Command Scheduler.
Jun 10 01:24:46 t440-linux crond[554]: (CRON) STARTUP (1.5.4)
Jun 10 01:24:46 t440-linux crond[554]: (CRON) INFO (Syslog will be used instead of sendmail.)
Jun 10 01:24:46 t440-linux crond[554]: (CRON) INFO (RANDOM_DELAY will be scaled with factor 50% if used.)
Jun 10 01:24:46 t440-linux crond[554]: (CRON) INFO (running with inotify support)
Jun 10 01:24:46 t440-linux CROND[568]: (root) CMD (sleep 10m && timeshift --create --scripted --tags B)[/color][/color]

Mein Problem ist halt das Timeshift die HDD dann nicht aufweckt um z.B. das stündliche Backup zu fahren.
Da ich gerade am vielen Probieren bin, und das mehrere Stunden hintereinander wäre dies für mich sehr hilfreich falls etwas schief gehen sollte :-)

Gruß
Sedi

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 787
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 5 Mal
Danksagung erhalten: 85 Mal

Re: HDD idle

#6

#6 Beitrag von gosia » Montag 10. Juni 2019, 15:32

Hallo Sedi,
tja, da muss wohl jemand anderes ran. Ich habe eine ähnliche Konstruktion, ein Skript, das einmal am Tag mittels crontab ein Backup auf eine externe FP schreibt und das läuft, ohne daß ich irgendwas anderes machen muss. Die externe FP schlummert vor sich hin und springt in dem Moment an, in dem crontab das Backup-Skript startet.
Aber es gibt ja andere User, die Timeshift benutzen, vielleicht können die was zum Problem beitragen. Das einzige, was mir auffällt, sind diese 10 Minuten sleep. Wieso 10 Minuten, Du machst doch nicht aller 10 Minuten ein Backup? Aber selbst das müsste eigentlich auch funktionieren.

viele Grüße gosia


Themen Author
Sedi
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 7
Registriert: Sonntag 9. Juni 2019, 14:46
CPU: i5-4200u
GPU: Intel Integrated HD-4400
Kernel: 4.19.45-1
DE: KDE
GPU Treiber: Mesa DRI Intel Haswell Mobile

Re: HDD idle

#7

#7 Beitrag von Sedi » Montag 10. Juni 2019, 15:37

Hi Gosia,

ich habe diese Einstellungen nicht vorgenommen.
Timeshift ist auf automatisches backup jede Stunde eingestellt.
Ansonsten mach ich weiter nichts mit der ecternen HDD. Komisch.
Da ich mich da nicht auskenne, lass ich das mal so laufen, mal schauen was ich noch so alles finde.

Danke für deine Mühe

Benutzeravatar

LQ
Forum Kenner
Forum Kenner
Beiträge: 202
Registriert: Donnerstag 5. Januar 2017, 05:43
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 2 Mal
Danksagung erhalten: 27 Mal

Re: HDD idle

#8

#8 Beitrag von LQ » Dienstag 11. Juni 2019, 09:46

Sedi hat geschrieben:
Montag 10. Juni 2019, 15:37
Da ich mich da nicht auskenne, lass ich das mal so laufen, mal schauen was ich noch so alles finde.
Ich würde AutoSuspend für USB-Geräte abstellen:

Code: Alles auswählen

sudo sed -i 's|USB_AUTOSUSPEND=1|USB_AUTOSUSPEND=0|' /etc/default/tlp
MfG
"Ceterum censeo M$ esse delendam"

Antworten