Boot dauert viel zu lange

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!

Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Boot dauert viel zu lange

#1

#1 Beitrag von manjaro2017 » Mittwoch 26. Juni 2019, 13:32

Hallo Leute,
Manjaro zu booten dauert viel zu lange habe mal systemd-analyze laufen lassen.
Und als erstes wird 18.311s man-db.service angezeigt wie kann man dieses problem lösen damit er schneller bootet ???

mfg
manjaro2017

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 960
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 120 Mal

Re: Boot dauert viel zu lange

#2

#2 Beitrag von gosia » Mittwoch 26. Juni 2019, 16:55

Hallo manjaro2017
probiere mal man-db,timer einzuschalten und zu starten, wenn noch nicht geschehen:

Code: Alles auswählen

sudo systemctl enable man-db.timer
sudo systemctl start man-db.timer
viele Grüße gosia


Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Re: Boot dauert viel zu lange

#3

#3 Beitrag von manjaro2017 » Mittwoch 26. Juni 2019, 17:58

Hallo Gosia,
leider keine besserung habe mal mit dem Handy nachgemessen 3 Min bis gebootet ist.
Das ist doch nicht normal
Habe es dann mal mit SSD probiert das selbe Ergebniss

mfg
manjaro2017

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 960
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 120 Mal

Re: Boot dauert viel zu lange

#4

#4 Beitrag von gosia » Mittwoch 26. Juni 2019, 18:56

Hallo manjaro2017,
na dann poste mal die Ausgabe von

Code: Alles auswählen

systemd-analyze blame
systemd-analyze critical-chain
viele Grüße gosia


Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Re: Boot dauert viel zu lange

#5

#5 Beitrag von manjaro2017 » Mittwoch 26. Juni 2019, 19:27

systemd-analyze blame

5.710s ModemManager.service
4.616s NetworkManager-wait-online.service
4.499s lvm2-monitor.service
3.319s nmb.service
3.217s dev-sda2.device
3.082s udisks2.service
2.836s polkit.service
2.525s NetworkManager.service
2.523s nfs-idmapd.service
2.372s grub-boot-indeterminate.service
2.335s avahi-daemon.service
2.325s gssproxy.service
2.323s systemd-logind.service
1.595s systemd-journal-flush.service
1.478s systemd-udevd.service
1.249s systemd-tmpfiles-clean.service
987ms tlp.service
637ms smb.service
622ms proc-fs-nfsd.mount
617ms systemd-modules-load.service
545ms org.cups.cupsd.service
542ms user@1000.service
526ms systemd-tmpfiles-setup-dev.service
508ms systemd-journald.service
447ms rpcbind.service
441ms rpc-statd.service
334ms systemd-udev-trigger.service
332ms upower.service
317ms systemd-random-seed.service
299ms dev-hugepages.mount
298ms dev-mqueue.mount
296ms sys-kernel-debug.mount
254ms nfs-server.service
232ms nfs-mountd.service
204ms nfsdcld.service
179ms systemd-tmpfiles-setup.service
167ms systemd-user-sessions.service
124ms systemd-binfmt.service
107ms dev-disk-by\x2duuid-c33e31f3\x2d41a1\x2d4040\x2d884b\x2dc3b37dcd38e1.swap
95ms systemd-sysctl.service
81ms kmod-static-nodes.service
70ms systemd-update-utmp.service



system-analyze critical-chain

The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @18.254s
└─multi-user.target @18.250s
└─ModemManager.service @7.116s +5.710s
└─basic.target @7.069s
└─paths.target @7.068s
└─org.cups.cupsd.path @7.068s
└─sysinit.target @6.980s
└─systemd-update-utmp.service @6.909s +70ms
└─systemd-tmpfiles-setup.service @6.719s +179ms
└─local-fs.target @6.716s
└─local-fs-pre.target @6.716s
└─lvm2-monitor.service @2.217s +4.499s
└─lvm2-lvmetad.service @2.515s
└─systemd-journald.socket @2.208s
└─system.slice @2.020s
└─-.slice @2.020s

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 960
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 120 Mal

Re: Boot dauert viel zu lange

#6

#6 Beitrag von gosia » Mittwoch 26. Juni 2019, 22:19

Hallo manjaro2017,
etwas schwierig. Schon weil man-db.service nicht mehr auftaucht und 3 Minuten Bootzeit an Hand der Angaben nicht nachvollziehbar ist. Soll nicht heissen, daß ich die 3 Minuten bezweifle, aber angezeigt werden "nur" ca. 56 Sekunden, was immer noch zu lang ist. Aber drehen kann man nur an Dingen, die man sieht :(
So kann man nur noch an Kleinigkeiten basteln, nach dem Motto "Kleinvieh macht auch Mist". Wenn Du keinen mobilen Breitbandanschluss hast (USB-Dongle, Mobil Phone u.ä.) kannst Du z.B. ModemManager.service abschalten, im Moment der größte Verbraucher.
Wenn Du keine Shares in der /etc/fstab hast, kannst Du auch NetworkManager-wait-online.service abschalten, wobei es bei dem oft notwendig ist, ihn "auszumaskieren"

Code: Alles auswählen

sudo systemctl disable NetworkManager-wait-online.service
sudo systemctl mask NetworkManager-wait-online.service
Ähnliches gilt für nmb.service -> hast Du kein Samba kann der Dienst ausgeschaltet werden. Weitere Kandidaten:
lvm2-monitor.service (hast Du LVM?)
nfs-idmapd.service (NFS benutzt?)
auf diese Art und Weise kannst Du dich durch die Dienste hangeln und nachsehen, was wirklich gebraucht wird. Aber ob das viel bringt, ausprobieren. Ich denke, die drei Minuten hängen (auch?) an andere Usachen, die ich jetzt nicht sehe. Mein Manjaro in einer VM auf einem älteren Laptop ist da schneller auf den Beinen.

viele Grüße gosia

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 2044
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.0
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 9 Mal
Danksagung erhalten: 67 Mal

Re: Boot dauert viel zu lange

#7

#7 Beitrag von Blueriver » Donnerstag 27. Juni 2019, 06:37

Hallo manjaro2017,

probier es mit

Code: Alles auswählen

sudo pacman -S haveged

sudo systemctl enable haveged --now
Danach das System neu starten.

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 960
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 120 Mal

Re: Boot dauert viel zu lange

#8

#8 Beitrag von gosia » Donnerstag 27. Juni 2019, 11:59

Hallo Blueriver,
danke, der Klassiker sozusagen. Hatte ich ganz vergessen.

viele Grüße gosia


Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Re: Boot dauert viel zu lange

#9

#9 Beitrag von manjaro2017 » Freitag 28. Juni 2019, 19:44

Blueriver hat geschrieben:
Donnerstag 27. Juni 2019, 06:37
Hallo manjaro2017,

probier es mit

Code: Alles auswählen

sudo pacman -S haveged

sudo systemctl enable haveged --now
Danach das System neu starten.
Hallo Blueriver,
merke keine unterschied dauert immer noch 3 Min bis zum Desktop


Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Re: Boot dauert viel zu lange

#10

#10 Beitrag von manjaro2017 » Freitag 28. Juni 2019, 19:46

Als Prozessor habe ich einen AMD Pheonom II X4 965 BE ist der echt zu langsam ???
WIindows 10 bootet mit SSD 12 Sekunden bis zum Desktop


Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Re: Boot dauert viel zu lange

#11

#11 Beitrag von manjaro2017 » Freitag 28. Juni 2019, 20:00

Ich denke vielleicht liegt es am Grub Loader kann das sein ???

mfg
manjaro2017


Daemon
Forum Kenner
Forum Kenner
Beiträge: 237
Registriert: Freitag 22. Dezember 2017, 14:17
CPU: 6082
GPU: wtf
Kernel: pre-linux
DE: pre-linux
GPU Treiber: hab keine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 14 Mal

Re: Boot dauert viel zu lange

#12

#12 Beitrag von Daemon » Freitag 28. Juni 2019, 21:35

Probier das was gosia geschrieben hat. Alles unnötige deaktivieren.


Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Re: Boot dauert viel zu lange

#13

#13 Beitrag von manjaro2017 » Freitag 28. Juni 2019, 22:22

Ich denke das hängt am grub loader
habe schon sachen raus geschmissen aber immer noch 3 Min und mit SSD dauert das auch voll lange

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 960
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 120 Mal

Re: Boot dauert viel zu lange

#14

#14 Beitrag von gosia » Freitag 28. Juni 2019, 23:50

Hallo manjaro2017,
manjaro2017 hat geschrieben:
Freitag 28. Juni 2019, 22:22
Ich denke das hängt am grub loader
Kann ich mir nicht vorstellen, denn dann wäre was an deiner grub.cfg verkehrt (keine Ahnung, was das sein sollte). Aber gut, wieviel Menueinträge hast Du denn drin?
Du kannst dir ja eine neue grub.cfg schreiben lassen
https://wiki.archlinux.de/title/GRUB#Au ... e_grub.cfg
Hängen die Bootmeldungen denn irgendwo länger, als sie eigentlich sollten? Ich hoffe, Du hast sie nicht durch Plymouth verdeckt? Wenn doch, Plymouth raus
https://wiki.manjaro.org/index.php?titl ... th#Removal
Das Problem ist, daß deine systemd-analyze keine drei Minuten ergibt. Insofern könnte es vielleicht auch am Anmeldevorgang beim Displaymanager liegen. Sind die drei Minuten vom Grub-Start bis zum Displaymanager gemessen oder bis zum Erscheinen des Desktop-Environments?

viele Grüße gosia


Themen Author
manjaro2017
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Freitag 18. August 2017, 22:05
GPU:
Kernel:
DE:
GPU Treiber:

Re: Boot dauert viel zu lange

#15

#15 Beitrag von manjaro2017 » Samstag 29. Juni 2019, 16:11

Wenn es nicht an grub hängen sollte müsste es ja fix mit SSD Platte gehen dauert aber genau so lang wie hdd.
Nur Manjaro und Windows 7
Wenn Manjaro bootet sehe ich gar nichts nur der Monitor ist aktiv und irgendwann kommt dann die Maus.
Die 3 Minuten ab Grub Start bis zum Desktop gemessen.
Plymouth ist nicht installiert.

Antworten