Dateimanager lässt sich nicht mehr als Root starten

Antworten
Benutzeravatar

Themen Author
m-bostaurus
Forum Kenner
Forum Kenner
Beiträge: 247
Registriert: Mittwoch 18. Mai 2016, 19:44
Wohnort: Nürnberg
CPU: AMD Ryzen 9 3950X / i5
GPU: nVidia GTX 1070Ti / nVidia
Kernel: 57/54
DE: stable (LXQt, Mate, KDE, XFCE)
GPU Treiber: nVidia - proprietär auf beiden Rechnern
Hat sich bedankt: 19 Mal
Danksagung erhalten: 8 Mal

Dateimanager lässt sich nicht mehr als Root starten

#1

#1 Beitrag von m-bostaurus »

Manchmal möchte ich aus Verwaltungsgründen meine Dateimanager (Pcmanfm-qt und Krusader) als Root starten. Das klappte bisher auch. Wie aus heiterem Himmel hörte es jedoch auf mit dem Klappen. Ich habe es bisher so gemacht: Alt+F2 > gksudo pcmanfm-qt oder auch gksudo krusader. Hat jemand eine Idee, wie ich dieses Hindernis wieder beseitigen kann?
Versuche ich, den Start aus dem Terminal zu machen, erhalte ich folgende Meldungen:

Code: Alles auswählen

sudo pcmanfm-qt
[sudo] Passwort für mz-c08: 

** (process:1726): WARNING **: The directory '~/Templates' doesn't exist, ignoring it

Code: Alles auswählen

sudo krusader
krusader(1763)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
KCrash: Application 'krusader' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
KCrash: Connect sock_file=/root/.kde4/socket-mz-pc/kdeinit4__0
Warning: connect() failed: : Datei oder Verzeichnis nicht gefunden
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi directly
drkonqi(1764)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch)
Die Meldungen und Hinweise verstehe ich nicht.
Benutzeravatar

bluelupo
Forum Kenner
Forum Kenner
Beiträge: 152
Registriert: Sonntag 15. Mai 2016, 16:42
Wohnort: Bayern
GPU:
Kernel:
DE:
GPU Treiber:

Re: Dateimanager lässt sich nicht mehr als Root starten

#2

#2 Beitrag von bluelupo »

Hi m-bostaurus,

im Falle von krusader ist das sehr wahrscheinlich ein Bug, da eine Kcrash-Meldung kommt. Die Meldung von pcmanfm-qt ist zu vage das ich dazu etwas sagen könnte.

Als Workaround könnte dir evtl. ein textbasierter Filemanager wie der Midnight Commander (mc) nutzen. Diesen kannst aus der Konsole starten.
Viele Grüße
bluelupo
Benutzeravatar

Themen Author
m-bostaurus
Forum Kenner
Forum Kenner
Beiträge: 247
Registriert: Mittwoch 18. Mai 2016, 19:44
Wohnort: Nürnberg
CPU: AMD Ryzen 9 3950X / i5
GPU: nVidia GTX 1070Ti / nVidia
Kernel: 57/54
DE: stable (LXQt, Mate, KDE, XFCE)
GPU Treiber: nVidia - proprietär auf beiden Rechnern
Hat sich bedankt: 19 Mal
Danksagung erhalten: 8 Mal

Re: Dateimanager lässt sich nicht mehr als Root starten

#3

#3 Beitrag von m-bostaurus »

Ich tät halt zwei Infos gerne haben: Woher kommt der Bug (wenn es einer ist)? Und: Was bedeutet der angebotene Workaround?

Code: Alles auswählen

To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)
Also was genau muss ich in das Terminal eingeben?

Goldhamster
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 9
Registriert: Sonntag 29. Mai 2016, 07:20
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 1 Mal

Re: Dateimanager lässt sich nicht mehr als Root starten

#4

#4 Beitrag von Goldhamster »

Moin,
ich hatte das gleiche Problem mit dem Krusader, den ich fast immer, als Dateimanager benutze.
Ich habe im anderen Manjaro-Forum die Lösung gefunden.
Die Lösung für Krusader ist:

Code: Alles auswählen

gksu dbus-launch krusader
Und schon lief er wieder.
Zuletzt geändert von Goldhamster am Donnerstag 15. September 2016, 10:43, insgesamt 1-mal geändert.
Benutzeravatar

Themen Author
m-bostaurus
Forum Kenner
Forum Kenner
Beiträge: 247
Registriert: Mittwoch 18. Mai 2016, 19:44
Wohnort: Nürnberg
CPU: AMD Ryzen 9 3950X / i5
GPU: nVidia GTX 1070Ti / nVidia
Kernel: 57/54
DE: stable (LXQt, Mate, KDE, XFCE)
GPU Treiber: nVidia - proprietär auf beiden Rechnern
Hat sich bedankt: 19 Mal
Danksagung erhalten: 8 Mal

Re: Dateimanager lässt sich nicht mehr als Root starten

#5

#5 Beitrag von m-bostaurus »

[quote="Goldhamster"]
Moin,
ich hatte das gleiche Problem mit dem Krusader, den ich fast immer, als Dateimanager benutze.
Ich habe im anderen Manjaro-Forum die Lösung gefunden.
Die Lösung für Krusader ist:

Code: Alles auswählen

gksu dbus-launch krusader
Und schon lief er wieder.
[/quote]Top! Das ist die Lösung! Auch für den normalen Dateimanager PCManFm! Danke!
Benutzeravatar

inxi
Forum Kenner
Forum Kenner
Beiträge: 171
Registriert: Montag 22. August 2016, 21:23
GPU:
Kernel:
DE:
GPU Treiber:

Re: Dateimanager lässt sich nicht mehr als Root starten

#6

#6 Beitrag von inxi »

Grafische Programme werden niemals mit sudo (ohne Option) gestartet.

Goldhamster
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 9
Registriert: Sonntag 29. Mai 2016, 07:20
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 1 Mal

Re: Dateimanager lässt sich nicht mehr als Root starten

#7

#7 Beitrag von Goldhamster »

Moin,
Grafische Programme werden niemals mit sudo (ohne Option) gestartet.
Blödsinn, dann versuche mir mal ganz langsam zu Erklären warum Krusader, u. a. wenn ich die als root starte, auch Thunar-root. starte mich nach dem Passwort fragen.
Benutzeravatar

djeli
Forum Held
Forum Held
Beiträge: 545
Registriert: Samstag 21. Mai 2016, 12:12
GPU:
Kernel:
DE:
GPU Treiber:
Hat sich bedankt: 17 Mal
Danksagung erhalten: 52 Mal

Re: Dateimanager lässt sich nicht mehr als Root starten

#8

#8 Beitrag von djeli »

Blödsinn, dann versuche mir mal ganz langsam zu Erklären warum Krusader, u. a. wenn ich die als root starte, auch Thunar-root. starte mich nach dem Passwort fragen.
Passwort wird immer abgefragt wenn der Benutzer gewechselt wird.(Ausnahme: Sie haben die gleichen berechtigungen).


Aus  https://wiki.ubuntuusers.de/sudo/
Der Befehl sudo ändert die Umgebungsvariable $HOME standardmäßig nicht auf den entsprechenden Pfad zum Ziel-Benutzer .
Startet man Programme mit sudo, besteht die Gefahr, dass Konfigurationsdateien mit falschen Rechten im Heimatverzeichnis des ursprünglichen Benutzers erstellt werden. Startet dieser das Programm später unter seinem eigenen Namen - also ohne sudo - so kann er die Konfiguration nur noch lesend oder eventuell gar nicht mehr öffnen. Daher sollte sudo immer mit der Option -H verwendet werden. Dies gilt auch bei Systembefehlen, die keine Konfigurationsdateien unter $HOME ablegen. Die grafischen sudo-Alternativen leiden nicht unter diesem Problem: Dort wird die Umgebungsvariable $HOME umgestellt.

Grafische Programme lassen sich in manchen Desktopumgebungen mit sudo -H nicht aus einem Terminal starten. Dies liegt daran, dass die Grafikumleitung nicht vollständig konfiguriert wird . Da sudo -H also nicht immer funktioniert und auch keine grafische Passwortabfrage erfolgt, sollten grafischen Anwendungen (unter anderem Namen) grundsätzlich über die grafischen Alternativen (wie gksudo/kdesudo) gestartet werden.
Benutzeravatar

bluelupo
Forum Kenner
Forum Kenner
Beiträge: 152
Registriert: Sonntag 15. Mai 2016, 16:42
Wohnort: Bayern
GPU:
Kernel:
DE:
GPU Treiber:

Re: Dateimanager lässt sich nicht mehr als Root starten

#9

#9 Beitrag von bluelupo »

An eine Regel sollte man sich immer halten auch wenn es manchmal verlockender ist das zu umgehen.

Als User niemals grafische Programmen (GUI's) im Kontext von Root starten und wenn man ehrlich zu sich selbst ist braucht man diese Funktionalität überhaupt nicht. Wenn's um kopieren oder veschieben von Dateien geht macht man dies auf der Kommandozeile im xterm/ux-term/konsole oder wer es komfortabler als Root mag nimmt den MidnightCommander (mc) in der Textkonsole.
Viele Grüße
bluelupo
Benutzeravatar

inxi
Forum Kenner
Forum Kenner
Beiträge: 171
Registriert: Montag 22. August 2016, 21:23
GPU:
Kernel:
DE:
GPU Treiber:

Re: Dateimanager lässt sich nicht mehr als Root starten

#10

#10 Beitrag von inxi »

Blödsinn, @Goldhamster? Eher Grundlagen!
Vielleicht beschäftigst du dich mal mit sudo....
Zuletzt geändert von inxi am Samstag 17. September 2016, 17:33, insgesamt 1-mal geändert.
Antworten