Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung? Thema ist als GELÖST markiert

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span

Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#31

#31 Beitrag von Clemens »

OK, fertig gerendert das dicke Ding. Resultat:
Renderzeit 2:13:26 - Dateigröße 4,313 GB

Format 1920x1080 @50 fps - yuv420p - Bitrate 20.702 kB/s - Audio 48 kHz 192 kB/s stereo

Am Ergebnis wundert mich, wieso jetzt die Video-Bitrate auf über 20 MB angestiegen ist. Das Ausgangsmaterial hatte 24.248 kB/s

Und beim letzten Versuch im obigen Thread hatte das Ausgangsmaterial eine VideoBitrate von 3591 kB/s. Diese erhöhte sich durch die Render-Definition global_quality=16 auf ca. 4.671 kB/s

Es könnte sein, dass global_quality ein Faktor ist, der sich auf die Bitrate des Quellmaterials bezieht. Es wäre doch sehr von Vorteil, wenn MLT hier mal Klarheit schafft, wie die verschiedenen Parameter beim Rendern das Endergebnis beeinflussen! So wie es jetzt ist, ist es schlicht MIST.
Ich hatte nicht vor, als Endprodukt eine solche Bitrate zu haben. Fast alle Videos, die ich produzieren will, werden im Web publiziert, wo solche Bitraten äußerst kontraproduktiv sind.

Zudem ist ja auch nach wie vor die Renderzeit über GPU einfach viel zu hoch!

Ich sehe aktuell keinen Ansatzpunkt, an dem ich mit meinen begrenzten zeitlichen und fachlichen Ressourcen jetzt noch optimieren kann. Ich bin echt drauf angewiesen, jemanden zu finden, der sich auskennt. Aber wo sollte ich fragen? Bei MLT? Bei ffmpeg? Bei Nvidia?

Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.4 LTS
DE: Gnome 3.36
GPU Treiber: nVidia 440.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 10 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#32

#32 Beitrag von zompel »

Auf Einzel-Computern wird nur Software-Rendering erwähnt. Falls man Harwdare-Rendern möchte, wird Intel mit der VA_API empfohlen. Von Nvidia keine Spur. In einem Ergänzungs-Dokument Ende 2019 wird beschrieben, dass GPU-Rendern über Nvidia von Usern zwar versucht werden kann, aber derzeit nichts supported wird und das eher nicht funktionieren wird. So jedenfalls habe ich deren Beschreibung verstanden.
Hab ich aus der Dokumentation nicht so verstanden...
Allerdings müsste man sich erst wieder in das Programm einarbeiten und man benötigt ja nicht unbedingt so viele Features wie angeboten. Bei Kdenlive ist die Lernkurve bestimmt viel flacher. Hab mal zum Spass Cinelerra GG installiert, aber "mal eben" was testen geht so schnell leider nicht :(
Ist mir im Moment zu viel, aber generell interessiert mich das Thema schon ein wenig...


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#33

#33 Beitrag von Clemens »

Gestern habe ich die Diskussion in das MLT-Forum getragen. Dieses wird als MLT-Abteilung bei Stackoverflow geführt.
https://stackoverflow.com/questions/615 ... th-gtx1650

Ferner hab ich im KDE-Forum die gleiche Frage gestellt:
https://bbs.archlinux.org/viewtopic.php ... 2#p1902562

Mal sehen, was kommt.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#34

#34 Beitrag von Clemens »

Tja, seit dem 03. Mai hat sich in keinem der anderen Foren oder hier noch etwas getan zu diesem Thema:

Entweder fällt niemandem mehr dazu etwas ein... oder ich werde durch Ignorieren abgestraft, weil cross-gepostet habe.

Falls letzteres zuträfe, fände ich das ganz schön blöde Prinzipienreiterei. Denn wenn nix mehr an Antworten kommt, kann ich doch meine Frage auch in anderen Foren posten in der Hoffnung, dass sich dort jemand auskennt! Zudem würde ich neue Ergebnisse dann doch überall wieder mitteilen, damit dann alle was davon haben.

Naja, was auch immer...
Durch Hardware-Vergleiche fand ich übrigens heraus, dass ich damals beim Hardwarekauf noch nicht daran gedacht hatte, auch Videos zu bearbeiten und daher nun auf einen viel zu lahmen CPU sitze. Heutzutage würde ein Intel-CPU-Upgrade bei 345 Euro liegen. Dafür bekomme ich aber ein neues Mainboard plus einer AMD-CPU, die viel leistungsfähiger ist, als mein jetziges System. Intel kann man wohl betr.Preis-Leistung heutzutage bei Desktops vergessen!

Übrigens betr. Kdenlive:
...die Verhältnisse sind ohne irgend welche Änderungen an Hard- oder Software noch schlechter geworden: Sobald ich einen transparenten Rahmen mit darauf gelegter Schrift über Teile mancher Einzelclips lege, gerät bereits die Vorschau im Vorschaufenster beim Abspielen ins Ruckeln und Stottern. Die Ruckler können so extrem werden, dass der Clip nur 1 Sekunde abspielt und dann ca. 0,5 Sekunden anhält. – Wenn ich dann speichere, Kdenlive beende und das Projekt neu starte, ruckelt es an der gleichen Stelle zunächst nicht. Aber wenn ich paar mal hin und her abgespielt habe, geht der Mist wieder los.

Diese Effekte sind völlig unabhängig davon, ob ich unter dem Vorschaufenster die Bildgröße auf 1:1 oder 720p oder 560p oder sonst was eingestellt habe!
Ich weiß aber nicht, was ich auslösen könnte in meinem System, wenn ich versuchsweise die Grafikkarte wieder ausbaue und den alten Intel-Zustand wieder herstelle mit Intel OnChip-Grafik 6000. Es ist immerhin mein Produktivsystem, auf dessen Verfügbarkeit und Zuverlässigkeit ich angewiesen bin.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#35

#35 Beitrag von Clemens »

Meine Erfahrungen mit der nVidia-Karte und kdenlive sind in totalem Ggensatz zu denjenigen eines YouTubers, der sich unicks.eu nennt. In zwei Videos zeigt er, wie stark das Rendern von Kdenlive unter Arch-Linux beschleunigt wird. In einem Beispiel sinkt die Renderzeit von 59 Minuten auf ganze 9 Minuten. – Von sowas kann ich nur träumen!

Unter "Einstellungen / nVidia Xserver-Einstellungen habe ich kontrollieren können, dass alle GL-Treiber und nVidia-Treiber korrekt eingebunden und aktiv sind.

Vielleicht hat ja doch noch jemand eine rettende Idee?

Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.4 LTS
DE: Gnome 3.36
GPU Treiber: nVidia 440.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 10 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#36

#36 Beitrag von zompel »

Leider weiß ich auch keinen Rat...
Ich glaube übrigens nicht, dass "absichtlich" niemand antwortet.
Ich würde gerne mal probieren ob ich es hinbekomme...
Vielleicht kannst du mir mal ein Videoschnipsel per https://wetransfer.com oder so zukommen lassen, aber ich weiß nicht ob ich die Zeit dafür finde. Also versprechen kann ich dir nichts!!


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#37

#37 Beitrag von Clemens »

Hi!
Leider hatte ich vergessen, die beiden YouTube-Videos hier zu verlinken.





Übrigens habe ich nie angenommen, dass "absichtlich" niemand antwortet. Das von mir vorgenomene CrossPosting wäre aber eine Erklärung, weil dies oft nicht gern gesehen wird. Aber offensichtlich weiß tatsächlich keiner eine Lösung, denn aus den anderen Foren kam ebenfalls keine Antwort!

Den Vorschlag betr. Videoschnipsel hattest du ja schon früher mal gemacht. Dafür danke ich dir!
Per PN hatte ich daraufhin einen Link zu dem Videoschnipsel gesendet. Der Link führt auf meine Website, ist aber sonst nicht durch andere Verlinkungen oder gar über die Navigation für Dritte zugänglich. Ich schick dir den nochmals per PN.

Seit dem 18. habe ich auch an dem Problem nicht mehr gearbeitet. Mittlerweile geht es ja nicht mehr nur um das Rendern für das Endprodukt, sondern auch um die Vorschau. Und das stört beim Schneiden gewaltig! Ein auf Zentel-sekunden genaues Schneiden ist kaum möglich, sobald ich z.B. einen Titel über den Clip gelegt habe, der außer Schrift mit Schlagschatten auch einen Rahmen hinter der Schrift mit transparenter Farbe (weiß) hat. Gerade hier hätte ich erwartet, dass die GPU ihre Stärken ausspielen kann!

Ich hab jetzt noch drei Videos von je ca. 50 Minuten Rohmaterial zu schneiden, sodass ca. je 20 Minuten Endprodukt heraus kommen. Mir graust es jetzt schon, unter diesen Bedingungen arbeiten zu müssen. Aber egal ob ich die TimeLine-Vorschau in der Auflösung reduziere oder auf CPU-Rendering umschalte, es ist immer das gleiche schlimme Ergebnis.

Benutzeravatar

zompel
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 57
Registriert: Montag 9. Dezember 2019, 19:52
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.4 LTS
DE: Gnome 3.36
GPU Treiber: nVidia 440.xx
Hat sich bedankt: 3 Mal
Danksagung erhalten: 10 Mal

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#38

#38 Beitrag von zompel »

Hallo Clemens :)
Ich habe immer noch keine PM von dir erhalten, ist aber auch nicht mehr nötig. Im ersten Video wird klar woran es liegen könnte.
Ich hatte dir schon einmal ein ziemlich alten Link geschickt - in dem es allerdings um Adobe Premiere ging - der genau das Problem beschrieb...
Einige Funktionen von Kdenlive unterstützen wohl GPU Hardware aber andere wieder nicht. Unter welchen Bedingungen es beschleunigt wird und unter welchen nicht, ist wohl nur mit viel experimentieren herauszufinden, was mir dann aber doch zu viel ist.
Tut mir Leid, dass ich mich hier ausklinken muss, aber ein Videoforum oder speziell eins wo Kdenlive behandelt wird wäre vielleicht passender.
Ich hoffe du findest für deine Zwecke eine passende Lösung *daumendrück*


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#39

#39 Beitrag von Clemens »

Danke für deine Antwort. Da ich alle Hände voll mit anderen Dingen zu tun habe, kann ich für kurzfristige Antworten hier im Forum nicht garantieren. Und manchmal gerät auch ein laufender Thread bei mir in Vergessenheit. Sorry, ist eben so.

Aber durch Diskussion im Kdenlive-Forum in einem anderen Thread, als den den ich hier nannte und durch Webrecherche fand ich schon vor über einem Monat heraus, dass die GPU-Unterstützung in Kdenlive gar nicht oder nur in Teilen funktioniert. Sie wurde dann im Herbst 2019 avisiert für die Kdenlive-Version im Sommer 2020.

Schaue ich mir die Roadmap für weitere Releases von Kdenlive an, so wurde offensichtlich die GPU-Hardware-Unterstützung wieder weiter heraus geschoben, ohne dafür eine Zeitangabe zu machen. Das Ganze liegt wohl auch nicht alleine in den Händen des Kdenlive-Teams, sondern auch bei der Unterstützung der GPU-Schnittstelle durch das MLT-Framework, für das Kdenlive (wie viele andere Schnitteditoren) nur eine GUI liefert und weitere Filter usw. von anderer Seite mit integriert zu einem Gesamtpaket.

Dies alles ist mir wohl bewusst, als ich hier bisher diskutiert hatte. Denn beide Videos zeigen ja auch, dass es eben TROTZ der eingeschränkten GPU-Unterstützung durch Kdenlive möglich ist, einen Geschwindigkeitsvorteil von 9 zu 58 zu erreichen! Das hätte ich auch gerne!

Da ich keine Website oder eMail-Adresse von "unicks.eu" habe, kann ich zu dem Autor keine Verbindung aufnehmen. Von seinem YouTube-Channel hat er sich gemnäß seinem eigenen Statement offensichtlich verabschiedet.


Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 155
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.5.19
DE: FXCE
GPU Treiber: Linux / nVidia free
Hat sich bedankt: 40 Mal
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: Nvidia GTX 1650 neu installiert - Überprüfung korrekter Einbindung?

#40

#40 Beitrag von Clemens »

Neuigkeiten gibt es!

Ich hab Shotcut ausprobiert. Denn im Forum von Shotcut fand ich den Hinweis, dass zwar manche Funkltionen noch nicht über die GPU laufen, wohl aber das Encoding / Rendern. Und dass die Vorschau mittels OpenGL erzeugt wird und auch dies über die GPU laufen soll.

Ein Testvideo, das mit Kdenlive bei mir ca 3 Minuten Renderzeit benötigt hatte, wird von Shotcut in ca. 15 Sekunden erledigt!
Spieldauer des Original-Video = 2:16 minuten bei 4,67 MB/s 25 fps und Audio mit 192 kB/s 48 kHZ stereo

Im Gegensatz zum Rendern von Kdenlive variiert die Renderzeit deutlich in Abhängigkeit von der Qualitätsvorgabe für das Renderprodukt und zwar beim Beispiel zwischen 12 Sekunden und 20 Sekunden. Bei Kdenlive war es bei mir immer bei ca. 3 Minuten.

Wie stark die GPU beteiligt war, das kann ich nicht feststellen, da ich dafür kein Tool habe.

Zudem habe ich bisher noch keine Ruckler in der Timeline festgestellt. Das muss ich aber noch mal prüfen, nachdem ich Titel / Schrift drüber gelegt habe.

Ich persönlich empfinde die GUI von Kdenlive deutlich besser gestaltet und die Bedienbarkeit besser organisiert als bei Shotcut. Kdenlive hab ich noch nicht ganz aufgegeben. Vielleicht muss beim Installationsprozess von Kdenlive bereits die Grafikkarte installiert und eingerichtet sein, damit es einwandfrei laufen kann? Shotcut fand diese Gegebenheit bei der Installation vor und hatte per default bereits die proprietären Nvidia-Treiber aktiviert.

Ich melde mich wieder, sobald ich mehr heraus gefunden habe.

Antworten